Error Tracking

Ao realizar a tentativa de instalar um pacote Laravel 5 que me permita utilizar modelos acessando o MongoDB, me deparei com o erro à seguir:


[UnexpectedValueException]
Could not parse version constraint ^1.0.1: Invalid version string "^1.0.1"

O motivo real do erro não foi possível identificar, porém, a solução é simples, principalmente se sua instalação do Composer é recente.

Solução

Execute a autoatualização do Composer e tente novamente a instalação do pacote desejado:

composer selfupdate

A instalação do pacote no meu caso:

composer require jenssegers/mongodb

Using version ~2.1 for jenssegers/mongodb
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
- Installing jenssegers/mongodb (v2.1.3)
Downloading: 100%

jenssegers/mongodb suggests installing jenssegers/mongodb-session (Add MongoDB session support to Laravel-MongoDB)
jenssegers/mongodb suggests installing jenssegers/mongodb-sentry (Add Sentry support to Laravel-MongoDB)

Espero que a dica ajude-o a resolver questões similares.

Referência

Fórum do site Laracast

Pin It on Pinterest

Share This

Share This

Share this post with your friends!